To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
Our Devops team was able to fix this issue quickly and Canvas is now fully functional. We apologize for the inconvenience this has caused, and appreciate your patience.
Posted Nov 07, 2020 - 18:55 MST
Investigating
We are currently investigating this issue.
Posted Nov 07, 2020 - 18:51 MST
This incident affected: Canvas (Canvas).