To view uptime history for your instance of Canvas, click here.

Some users are unable to access Canvas
Incident Report for Instructure
Resolved
Our Ops team were able to implement a fix for the failing drive. We are now seeing Canvas performance back to optimal levels. We're very sorry for any inconvenience this may have caused you and appreciate your patience.
Posted May 14, 2018 - 14:19 MDT
Monitoring
Our Ops team has finished rebuilding a failed drive that was causing the page errors with Canvas. Although we are starting to see performance improvements for users, we will continue to monitor until we are comfortable that there are no more interruptions for users. Thank you for your patience.
Posted May 14, 2018 - 14:05 MDT
Identified
Our Ops team have identified the cause of the degraded performance for the US-Northwest Region of Canvas. We are currently working to restore performance back to optimal levels. We will post an update once a fix is in place. Thank you for your patience with this situation.
Posted May 14, 2018 - 13:58 MDT
Investigating
Some users are experiencing long load times or page errors when trying to access Canvas. Our DevOps team is currently investigating the cause of this problem, and we'll post an update shortly. We sincerely apologize for any inconvenience this may be causing you.
Posted May 14, 2018 - 13:26 MDT
This incident affected: Canvas (Canvas LMS).