To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page errors when accessing Canvas
Incident Report for Instructure
Resolved
Our developers implemented a fix and the issue is resolved. We will continue to monitor the issue and look for any other issues.
Posted Jan 29, 2021 - 17:51 MST
Investigating
We are currently investigating this issue.
Posted Jan 29, 2021 - 17:38 MST