To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
Canvas access has returned to normal and users should be able to access as normal.
Posted Apr 28, 2019 - 19:20 MDT
Identified
We have been able to find the cause of this issue. We have implemented a fix for this and load times are scaling back to normal.
Posted Apr 28, 2019 - 19:02 MDT
Investigating
we are currently investigating slow load times and users running into error messages when they are attempting to access Canvas.
Posted Apr 28, 2019 - 18:55 MDT
This incident affected: Canvas (Canvas LMS).