To view uptime history for your instance of Canvas, click here.

Canvas Chat Support Downtime
Incident Report for Instructure
Resolved
The maintenance window for the Canvas Support chat is now closed and is be operating normally.
Posted Mar 19, 2022 - 22:55 MDT
Identified
The Canvas Support chat system will be undergoing maintenance. This is anticipated to last from 10:30PM MDT to 10:50PM MDT. During this time users may have trouble contacting Canvas support via chat. If you need to contact the support team during this time, consult your Canvas "Help" tab to find your contact options.
Posted Mar 19, 2022 - 22:29 MDT