To view uptime history for your instance of Canvas, click here.

Some users are experiencing slow load times and page errors
Incident Report for Instructure
Resolved
Canvas continues to load properly for users. We appreciate your patience as we worked to resolve this today.
Posted Aug 24, 2020 - 16:15 MDT
Monitoring
Load times to the Free For Teacher and Canvas Network instances have stabilized and users should now be able to access them.
Posted Aug 24, 2020 - 15:51 MDT
Investigating
We have received reports that users are encountering page errors and long load times when accessing CanvasNet and the Free For Teacher instance of Canvas. Our team is investigating.
Posted Aug 24, 2020 - 13:13 MDT
Monitoring
Load times have stabilized and returned to normal. We will continue to monitor and ensure that it is all corrected.
Posted Aug 24, 2020 - 12:36 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 24, 2020 - 09:22 MDT
Update
We’re seeing improvements across most instances, however some users may still experience slow load times, which our team is still actively working to fix
Posted Aug 24, 2020 - 09:15 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 24, 2020 - 09:09 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 24, 2020 - 08:18 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2020 - 08:07 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2020 - 07:03 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2020 - 06:45 MDT
This incident affected: Canvas (Canvas, — Catalog, — Imports and exports, — Notifications).