To view uptime history for your instance of Canvas, click here.

A small subset of users experiencing long load times
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 09:23 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2020 - 09:08 MDT
Investigating
We're seeing that a small subset of users experiencing long load times. Our DevOps teams is currently investigating the issue, we'll provide an update on this shortly.
Posted Jul 28, 2020 - 08:56 MDT
This incident affected: Canvas (Canvas).