Some users are experiencing 504 errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 09:10 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2020 - 08:51 MDT
Investigating
We are currently investigating this issue
Posted Apr 29, 2020 - 08:45 MDT
This incident affected: Canvas (Canvas).