To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are seeing longer load times while importing and exporting files in Canvas.
Incident Report for Instructure
Resolved
Canvas load times are now returning back to expected performance levels. We appreciate your patience and sincerely apologize for any inconvenience this may have caused you.
Posted Mar 16, 2019 - 16:26 MDT
Update
We are still continuing to monitor these slower load times for any further issues. We thank you for your patience.
Posted Mar 16, 2019 - 16:21 MDT
Update
We are still continuing to monitor these slower load times. We thank you for your patience.
Posted Mar 16, 2019 - 16:06 MDT
Monitoring
Our engineering team has identified the issue and is currently monitoring load times for a full resolution. Once again, thank you for your patience.
Posted Mar 16, 2019 - 15:50 MDT
Update
Our engineers are still looking into this behavior. We'll post another update when we have further details. Thank you for your patience.
Posted Mar 16, 2019 - 15:34 MDT
Investigating
Some users are seeing longer load times while importing and exporting files in Canvas. Our engineers are aware of the increase in load times, and are currently working to mitigate the behavior.
Posted Mar 16, 2019 - 15:18 MDT
This incident affected: Canvas (— Imports and exports).