To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 19:35 MDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 24, 2020 - 19:29 MDT
Identified
Our engineers have identified the issue and are working on a resolution.
Posted Mar 24, 2020 - 19:07 MDT
Update
We are continuing to investigate this issue.
Posted Mar 24, 2020 - 18:54 MDT
Investigating
We are currently investigating this issue.
Posted Mar 24, 2020 - 18:54 MDT
This incident affected: Canvas (Canvas LMS).