To view uptime history for your instance of Canvas, click here.

Users experiencing issues while accessing parts of Mastery Connect
Incident Report for Instructure
Resolved
The issue has been resolved.
Posted Jun 13, 2023 - 15:23 MDT
Investigating
We are experiencing a major outage due to an issue that Amazon Web Services is having.

Assessments, Items, Users, Sections and any new user content will not be available in searches, indexes, and lists. New scores are not populating in the tracker or reports. Emails are not being sent to users (including password resets).
Posted Jun 13, 2023 - 14:25 MDT
This incident affected: Mastery (Mastery Connect).