To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
All access to Canvas should be as normal. We apologize for any inconvenience it may have caused.
Posted Nov 25, 2019 - 10:53 MST
Monitoring
Our DevOps team was able to determine the cause of the error messages and slow load times. Performance within Canvas for effected users should now be resolved. We will continue to monitor this behavior
Posted Nov 25, 2019 - 10:45 MST
Investigating
We have reports of US based users running into slow load time and error messages when attempting to access Canvas. We are currently investigating these reports
Posted Nov 25, 2019 - 10:33 MST
This incident affected: Canvas (Canvas LMS).