To view uptime history for your instance of Canvas, click here.

Slow load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved by our team.
Posted Sep 30, 2020 - 14:46 MDT
Update
We are continuing to monitor for any further issues.
Posted Sep 30, 2020 - 14:28 MDT
Monitoring
Load times have stabilized for the affected users. We will continue to monitor to ensure the fix put in place by our team continues and load times stay improved.
Posted Sep 30, 2020 - 14:28 MDT
Identified
Our team has identified the cause of the load times and are currently looking into adjusting the necessary resources to help with the load times.
Posted Sep 30, 2020 - 14:14 MDT
Investigating
Some users are seeing slow load times when they are accessing Canvas. Our team is currently investigating the cause of the load times.
Posted Sep 30, 2020 - 13:51 MDT
This incident affected: Canvas (Canvas LMS).