To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 11:41 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2020 - 11:36 MDT
Update
We are continuing to investigate this issue.
Posted Mar 18, 2020 - 11:33 MDT
Investigating
We are currently investigating this issue.
Posted Mar 18, 2020 - 11:33 MDT
This incident affected: Canvas (Canvas).