To view uptime history for your instance of Canvas, click here.

Users at some Canvas institutions experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Our engineers were able to resolve the issue for users who were unable to access their Canvas site. All users should now be able to log into and access their Canvas courses. Pleas do not hesitate to contact us if you see anything to the contrary. We apologize for any inconvenience or frustration that this has caused.
Posted Apr 29, 2015 - 13:14 MDT
Update
Our DevOps team continues to investigate the issue causing page errors when attempting to access Canvas. We will provide more information as soon as we can.
Posted Apr 29, 2015 - 12:49 MDT
Investigating
A small percentage of Canvas users are currently experiencing errors when attempting to access the application. Our Operations team is working on the issue. We'll prove an update in 20 minutes.
Posted Apr 29, 2015 - 12:24 MDT