To view uptime history for your instance of Canvas, click here.

Some users are seeing errors and slow load times when accessing New Quizzes

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Jan 31, 2025 - 12:48 MST

Update

A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2025 - 12:44 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 31, 2025 - 12:42 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 31, 2025 - 11:45 MST
This incident affected: AWS Region (us-west-2).