To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas from Europe.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 17, 2020 - 08:34 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 17, 2020 - 08:26 MST
Investigating
Canvas is currently experiencing slow load times or error messages when accessing Canvas for the EMEA region.
Posted Dec 17, 2020 - 08:21 MST
This incident affected: Canvas (Canvas LMS).