To view uptime history for your instance of Canvas, click here.

Incoming Calls Unavailable

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 01:27 MDT

Investigating

We are currently investigating an issue with our phone system that is preventing our agents from receiving incoming calls. Our team is actively working to restore service as quickly as possible. In the meantime, you can reach out to support via chat and email, which are fully operational. We will continue to provide updates as the situation develops.
Posted Apr 22, 2025 - 23:51 MDT
This incident affected: Support Tools (Support: Phones/Chat).