To view uptime history for your instance of Canvas, click here.

Some users hosted in our PDX region are unable to load images.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 07:09 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2021 - 06:54 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2021 - 06:50 MST
Investigating
We are currently investigating this issue.
Posted Dec 14, 2021 - 06:39 MST
This incident affected: Canvas (Canvas).