To view uptime history for your instance of Canvas, click here.

C241 Slowness and Timeout Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 10, 2021 - 19:07 MST
Update
We are continuing to investigate this issue.
Posted Mar 10, 2021 - 18:37 MST
Investigating
We are currently investigating this issue.
Posted Mar 10, 2021 - 18:37 MST