To view uptime history for your instance of Canvas, click here.

Canvas Support phone system problems
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 03, 2022 - 23:36 MST
Investigating
Canvas Support is currently having an issue with our phone provider, If you are trying to contact Canvas Support at this time we would recommend that you reach out to us via our chat system.
Posted Mar 03, 2022 - 23:30 MST
This incident affected: Support Tools (Support: Phones/Chat).