To view uptime history for your instance of Canvas, click here.

A very small group of users are experiencing long load times or page time outs when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 01, 2021 - 07:15 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2021 - 07:10 MST
This incident affected: Canvas (Canvas).