Users may have experienced the error "This website is under heavy load" in Canvas.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Jun 12, 2024 - 12:07 MDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2024 - 11:56 MDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2024 - 11:41 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2024 - 11:27 MDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2024 - 11:26 MDT

Investigating

We are currently investigating this issue.
Posted Jun 12, 2024 - 11:25 MDT
This incident affected: Canvas (Canvas LMS).