To view uptime history for your instance of Canvas, click here.

Video file uploads having increased time to process when using Studio
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 05, 2024 - 11:49 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2024 - 11:44 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2024 - 11:42 MDT
Update
We are continuing to investigate this issue.
Posted Jun 05, 2024 - 11:17 MDT
Investigating
We are currently investigating this issue.
Posted Jun 05, 2024 - 11:15 MDT
This incident affected: AWS Region (eu-west-1, us-east-1, us-west-2) and Canvas (Canvas Studio).