To view uptime history for your instance of Canvas, click here.

"Service is currently not available. Try again later" error for some users when accessing files in Canvas

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Sep 15, 2022 - 07:13 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2022 - 07:08 MDT

Identified

Some users may be experiencing an error when trying to view files within Canvas. We have identified the cause of this error and are working to implement a fix.
Posted Sep 15, 2022 - 06:58 MDT
This incident affected: Canvas (Canvas LMS) and AWS Region (us-east-1).