To view uptime history for your instance of Canvas, click here.

Users unable to access Commons.
Incident Report for Instructure
Resolved
Our engineering team was able to implement a solution for this behavior. Again, we apologize for any inconvenience this may have caused you.
Posted Mar 06, 2019 - 12:19 MST
Identified
We have received reports of slowness and page errors when users attempt to access Commons. Our engineering team has identified the cause and is working to implement a solution. We apologize for any inconvenience this may have caused.
Posted Mar 06, 2019 - 11:44 MST
This incident affected: Canvas (Canvas Commons).