To view uptime history for your instance of Canvas, click here.

Some users are experiencing 504 errors and slowness when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 17:59 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2020 - 17:50 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 28, 2020 - 17:42 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 28, 2020 - 17:32 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2020 - 17:22 MDT
Investigating
Some users are experiencing timeouts and page errors when attempting to access Canvas. We're currently investigating this issue, and will provide an update soon.
Posted Apr 28, 2020 - 17:13 MDT