To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas.

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 07:31 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 04, 2025 - 07:18 MST
This incident affected: Canvas (Canvas LMS) and AWS Region (ca-central-1).