To view uptime history for your instance of Canvas, click here.

Some users experiencing long load times when creating objects.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 12:10 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2020 - 10:49 MDT
Investigating
We are currently investigating this issue.
Posted Apr 06, 2020 - 09:41 MDT