To view uptime history for your instance of Canvas, click here.

Canvas Catalog is timing out for some users in the US.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 05, 2024 - 14:37 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2024 - 14:35 MDT
Investigating
We are currently investigating this issue.
Posted Aug 05, 2024 - 14:30 MDT
This incident affected: Canvas (Canvas Catalog).