To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing slowness or page timeout errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 10:23 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2020 - 10:08 MDT
Identified
Our Engineers have Identified the cause of the issue, and are working to implement a fix.
Posted Oct 09, 2020 - 09:52 MDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2020 - 09:37 MDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2020 - 09:24 MDT
Investigating
A small subset of users are experiencing slowness or page timeout errors when accessing Canvas. Our DevOps team is currently investigating the issue, and we'll provide an update shortly.
Posted Oct 09, 2020 - 09:09 MDT
This incident affected: Canvas (Canvas LMS).