To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 18, 2020 - 11:41 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 18, 2020 - 11:27 MDT
Identified
Our DevOps team has identified the issue, and working on a fix. We'll provide an update in a few minutes.
Posted Aug 18, 2020 - 11:09 MDT
Investigating
Our DevOps team is currently investigating the issue, we'll provide an update shortly.
Posted Aug 18, 2020 - 10:54 MDT
This incident affected: Canvas (Canvas).