To view uptime history for your instance of Canvas, click here.

a small amount of users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 19, 2020 - 09:37 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2020 - 09:28 MDT
Investigating
A small amount of users are experiencing long load times or page time outs when accessing Canvas. We are currently investigating this issue
Posted Aug 19, 2020 - 09:20 MDT
This incident affected: Canvas (Canvas).