To view uptime history for your instance of Canvas, click here.

Some users receiving errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved and users can access Canvas normally again.
Posted Nov 17, 2022 - 18:57 MST
Investigating
We are currently investigating some users getting a heavy page load error when trying to access Canvas.
Posted Nov 17, 2022 - 18:51 MST
This incident affected: Canvas (Canvas LMS, Canvas Catalog, Canvas Commons, Student ePortfolios, Canvas Studio, Canvas Credentials, Canvas Mobile, Student Pathways) and AWS Region (us-east-1).