To see historical uptime for Canvas and other services for a specific instance, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operational parameters, and we appreciate your patience while our team looked into this.
Posted Feb 24, 2020 - 08:56 MST
Monitoring
Our Devops Team was able to identify the issue, and deploy a fix. We're not longer seeing users experiencing long load times, but we'll monitor the behavior for the next few minutes.
Posted Feb 24, 2020 - 08:44 MST
Investigating
Some users are experiencing long load times or page time outs when accessing Canvas. Our DevOps team is aware and currently investigating the issue, we'll provide an update shortly.
Posted Feb 24, 2020 - 08:39 MST
This incident affected: Canvas (Canvas).