Our engineering team has identified the issue and has implemented a fix. This fix is being monitored.
Posted Oct 04, 2023 - 17:45 MDT
Investigating
Some users are experiencing the following page error when attempting to access Canvas:
"This website is under heavy load (request timed out) We're sorry, too many people are accessing this website at the same time. We're working on this problem. Please try again later."
Our engineering team is currently investigating this issue. Thank you for your patience.
Posted Oct 04, 2023 - 17:34 MDT
This incident affected: Instructure and AWS Region (ap-southeast-1).