To view uptime history for your instance of Canvas, click here.

Canvas Page Errors and Slow Page Loading - IAD

Incident Report for Instructure

Resolved

Our engineering team has implemented a fix, and the issue has been resolved.
Posted Apr 28, 2022 - 15:25 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2022 - 15:17 MDT

Investigating

Some users in the IAD region are experiencing page errors - 'connection to server at "cluster17-bouncer-vpc.us-east-1c.canvas.insops.net."' Our engineering team is currently investigating this issue.
Posted Apr 28, 2022 - 15:01 MDT
This incident affected: Canvas (Canvas LMS).