To view uptime history for your instance of Canvas, click here.

A subset of users are experiencing long load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 06:03 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2020 - 06:01 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2020 - 05:52 MST
Investigating
We are currently investigating this issue.
Posted Dec 14, 2020 - 05:47 MST
This incident affected: Canvas (Canvas LMS).