We are continuing to monitor for any further issues.
Posted May 11, 2026 - 16:19 MDT
Monitoring
Canvas Beta and Canvas Test are now available.
Posted May 11, 2026 - 16:18 MDT
Update
Canvas is now available for most users.
Canvas Beta and Canvas Test remain in maintenance.
Posted May 07, 2026 - 21:17 MDT
Update
Instructure has placed Canvas, Canvas Beta and Canvas Test in maintenance mode. We anticipate being up soon, and will provide updates as soon as possible