To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times or page time outs when accessing Canvas
Incident Report for Instructure
Resolved
Our team was able to identify the cause of the slow load times and they have implemented a fix. Load times have returned to normal.
Posted May 11, 2020 - 06:07 MDT
Investigating
We have received reports that some users are experiencing longer load times and in some cases page time outs when accessing Canvas. Our team is currently investigating the cause of this.
Posted May 11, 2020 - 05:54 MDT
This incident affected: Canvas (Canvas LMS).