To view uptime history for your instance of Canvas, click here.

Canvas "Page Not Found" Errors - IAD
Incident Report for Instructure
Resolved
Our engineering team has deployed a fix, and this incident has been resolved.
Posted May 24, 2022 - 18:32 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2022 - 18:20 MDT
Investigating
Some users in the IAD region are experiencing page errors when accessing Canvas. Our engineering team is currently investigating this issue.
Posted May 24, 2022 - 17:00 MDT
This incident affected: Canvas (Canvas).