To view uptime history for your instance of Canvas, click here.

Users experiencing long job processing times
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 11, 2020 - 17:45 MDT
Update
We are continuing to monitor the situation and will provide an update once Canvas is back to full functionality. Thank you!
Posted May 11, 2020 - 17:05 MDT
Update
We are continuing to monitor for any further issues.
Posted May 11, 2020 - 16:39 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2020 - 16:11 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2020 - 16:01 MDT
Update
We are still actively investigating this issue.
Posted May 11, 2020 - 15:50 MDT
Update
We are continuing to investigate this issue.
Posted May 11, 2020 - 15:27 MDT
Investigating
Some institutions may be experiencing long job processing times. Canvas functionality that may be affected include SIS imports, Gradebook exports, Course migration, and Canvas notifications.
Posted May 11, 2020 - 15:27 MDT