To view uptime history for your instance of Canvas, click here.

Customers are not able to use the Impact product due to an AWS outage.
Incident Report for Instructure
Resolved
The issue has been resolved.
Posted Dec 02, 2022 - 07:48 MST
Investigating
Amazon Web Services is experiencing an outage. Customers in the US-West-2 region are not able to use the Impact product.
Posted Dec 01, 2022 - 08:06 MST
This incident affected: Impact and AWS Region (us-west-2).