To view uptime history for your instance of Canvas, click here.

Slow load times impacting some Canvas users.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 14:59 MDT
Monitoring
Our developers have identified the issues. Users should not be experiencing any slowness but we will continue to monitor.
Posted Sep 15, 2021 - 14:47 MDT
Identified
We've been seeing slowness on some servers due to heavy traffic.
Posted Sep 15, 2021 - 14:45 MDT
This incident affected: Canvas (Canvas LMS).