To view uptime history for your instance of Canvas, click here.

Some US based schools are running into longer than normal load times
Incident Report for Instructure
Resolved
The issue has been resolved, and Canvas is loading normally once again. Thank you so much for your patience.
Posted Aug 20, 2019 - 11:54 MDT
Monitoring
our DevOps team was able to determine the cause of this slowness and have implemented a fix. We will continue to monitor the performance of Canvas.
Posted Aug 20, 2019 - 07:41 MDT
Investigating
We are receiving reports that Canvas is experiencing longer than normal load times for some schools based in the US. We have our DevOps team investigating this issue
Posted Aug 20, 2019 - 07:34 MDT
This incident affected: Canvas (Canvas LMS).