To view uptime history for your instance of Canvas, click here.

Some Canvas users are experiencing long load times and time out errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 12, 2023 - 07:38 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 07:16 MDT
Update
We are continuing to investigate this issue.
Posted May 12, 2023 - 07:16 MDT
Investigating
Our team is working hard to restore functionality for all Canvas users.
Posted May 12, 2023 - 07:13 MDT
This incident affected: Instructure.