Some users may experience longer load times when accessing Canvas Outcomes

Incident Report for Instructure

Resolved

This incident has been resolved.
Posted Nov 27, 2024 - 20:58 MST

Investigating

We are currently investigating this issue.
Posted Nov 27, 2024 - 20:52 MST
This incident affected: Canvas (Canvas LMS).