To view uptime history for your instance of Canvas, click here.

Errors when accessing Student View
Incident Report for Instructure
Resolved
The errors received when accessing student view have been resolved by our team. Thank you for your patience.
Posted Aug 24, 2020 - 15:53 MDT
Investigating
Some users are experiencing errors when accessing Student View inside of Canvas.
Posted Aug 24, 2020 - 14:48 MDT
This incident affected: Canvas (Canvas).