To view uptime history for your instance of Canvas, click here.

Some users are experiencing timeout errors when attempting to access Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved. We appreciate your patience and apologize for any inconvenience this may have caused.
Posted May 02, 2020 - 00:49 MDT
Monitoring
Some users are experiencing timeout errors when attempting to access Canvas. We're currently investigating this issue, and will provide an update soon.
Posted May 02, 2020 - 00:28 MDT
Investigating
Some users are experiencing timeout errors when attempting to access Canvas. We're currently investigating this issue, and will provide an update soon.
Posted May 01, 2020 - 23:57 MDT
This incident affected: Canvas (Canvas LMS).