To view uptime history for your instance of Canvas, click here.

Some users seeing slow load times while accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Feb 14, 2019 - 12:44 MST
Monitoring
Users are seeing normal page load times again, we will monitor to ensure that sadness does not return.
Posted Feb 13, 2019 - 12:44 MST
Investigating
We are investigating reports of slowness in Canvas for some US-based users.
Posted Feb 13, 2019 - 12:19 MST
This incident affected: Canvas (Canvas LMS).